Manual: Menus

From OpenMPT Wiki
Jump to: navigation, search

In all menu screenshots, the keyboard shortcuts are shown but may be different from your own. You can configure these in the Keyboard setup.

File Menu

File[edit]

  • New: Creates a blank track. You can select the track type from the sub menu. When using the shortcut for a new track, OpenMPT defaults to an IT track if no other documents are open, and if there are other documents open, it will default to the track type of the currently active document.
  • Open: Loads one or more tracks you want to open and adds them to the Recent Files list. OpenMPT can open a variety of file formats, listed in the Module formats section.
  • Open Template: Provides a list of modules that have previously been saved as templates.
  • Append Module: Appends (merges) the song data (samples, instruments, plugins, patterns and sequences) of one or more existing songs to the currently active song.
  • Close: Closes the currently active track. If changes were made (shown by an asterisk in OpenMPT’s title bar), you will be prompted if you wish to save the changes.
  • Close All: Closes all open tracks. You will be prompted to save any modified tracks.
  • Save: Saves the file in its current directory with its current name. If the file is new and was never saved, this command is the same as the “Save As” menu item.
  • Save As: Opens a dialog where you can specify a location you wish to store the file to.
  • Save as Template: Saves the currently open module as a template module.
  • Export as lossless: Exports the track to a lossless audio file (WAV, FLAC).
  • Export as lossy: Exports the track to a lossy audio file (Opus, OGG Vorbis, MP3).
  • Export as MIDI: Exports the track to a .mid sequencer file.
  • Compatibility Export: Exports the track to a “pure” version of the track format. See the section on Compatibility Export for more details. The track itself is not modified.
  • Import MIDI Library: Shows the Open File dialog so you can load a new default MIDI library, which will overwrite your current MIDI library in the Tree View.
  • Add Sound Bank: Shows the Open File dialog so you can append another sound bank folder into the Tree View.
  • Recent Files List: Lists the last 10 files that were opened in OpenMPT. The shortcut keys are the digits 1 to 0.
  • Exit: Executes the Close command on all files (see above), saves all settings and quits ModPlug Tracker.
Player Menu

Player[edit]

  • Pause / Resume: Pauses the song. All audio processing is stopped; when resuming playback from Pause, audio processing is restarted from the last cursor position in the pattern editor.
  • Play from Start: Resets the playback position to the beginning of the first pattern in the Order List, and begins playback.
  • Stop: Stops all audio processing and resets the playback position.
  • Pause: Pauses the song by stopping audio processing, but NOT resetting the playback position.
  • MIDI Record: Allows MIDI messages to be received from the device specified in the MIDI setup. This device can then be used to enter notes and other MIDI data in the pattern, sample and instrument editors. See the section on MIDI Setup, MIDI Mapping, or MIDI in ModPlug for more details.
  • Estimate Song Length: Displays a window which shows an estimate of the song length. When working with multiple sequences, only the current sequence is considered in the calculation.
  • Approximate Real BPM: Displays a window which shows an estimate of the actual tempo in terms of Beats per Minute (BPM), based on Tempo Mode, the tempo value, and the ticks-per-row value (speed).
Edit Menu

Edit[edit]

  • Undo: Withdraws the last action taken. This only occurs in the Pattern Editor and Sample Editor. There is a limit to the number of Undo steps — 100,000 for Pattern edits and 100,000 for edits of each sample. Pattern navigation and selection cannot be un-done. For samples, you can also limit the amount of RAM used by the Undo buffer in the INI file.
  • Redo: Reapplies the last undone action.
  • Cut: Executes a Copy action, then erases all data from the selected area.
  • Copy: Copies the selection to the clipboard.
  • Paste: Transfers a copy of the clipboard contents where the cursor is located, overwriting any data within the bounds of the pasted data. For pattern data, the clipboard content will be pasted in the same cell as the cursor location, even if the cursor is not in the first column of the event. For sample data, pasting replaces the complete samples, i.e. you cannot paste into an existing sample.
  • Paste Special: Opens a sub menu where you can choose alternate forms of pasting data into patterns, as described in the Pattern Editor manual.
  • Select All: Selects all data in the location of the input focus (the Pattern Editor or the Sample Display). The cursor remains in the same location.
  • Cleanup: Opens the Cleanup Manager dialog, which allows you to remove, reset, or re-arrange track elements such as patterns and samples.
  • Find: Opens the Find & Replace dialog, where you can search for data and replace it if necessary.
  • Find Next: Finds the next occurrence of data according to your previous filters in the Find dialog.
  • Go To: Opens a dialog where you can choose to navigate to another pattern location.
  • Split Keyboard Settings: Opens the Keyboard Split dialog.
View Menu

View[edit]

  • General Tab: Displays the General Page of the currently active module.
  • Patterns Tab: Displays the Patterns Page.
  • Samples Tab: Displays the Samples Page.
  • Instruments Tab: Displays the Instruments Page.
  • Comments Tab: Displays the Comments Page.
  • Main: Toggles the display of the Main Toolbar, remembering its position.
  • Tree: Toggles the display of the Folder Tree View.
  • Setup: Shows the Setup Options dialog at the last open page.
  • Plugin Manager: Shows the Plugin Manager dialog.
  • Channel Manager: Shows the Channel Manager dialog.
  • Clipboard Manager: Shows the Clipboard Manager dialog.
  • Song Properties: Shows the Song Properties dialog.
  • Zxx Macro Configuration: Shows the MIDI Macro Configuration dialog.
  • MIDI Mapping Options: Shows the MIDI Mapping dialog.
  • Edit History: Shows the Edit History dialog.
  • Find OpenMPT Hacks: Lists the non-standard (non-compatible) modifications in the current track introduced by ModPlug Tracker. This helps to show what needs to be changed so that other trackers or players can play the file correctly.
Window Menu

Window[edit]

New Window: Opens an alternate window of the current track using the same page display.

  • Cascade Windows: Resizes and “cascades” all open windows (by superimposing one over the other diagonally) so that any window can be brought to the front with a mouseclick on that window.
  • Tile Windows Horizontal: Resizes all open windows so that horizontally they equal the width of OpenMPT’s window, and vertically they share an equal amount of space between the Menu Bar and the Status Bar.
  • Tile Windows Vertical: Resizes all open windows so that vertically they equal the height of OpenMPT’s window, and horizontally they share an equal amount of space between the Folder Tree and the right side of OpenMPT’s window.
  • Arrange Icons: All minimized child windows are moved back to the lower-left corner of the main window, where they are located by default.
  • Split: Allowes a page to be split horizontally. Selecting this menu item centers the mouse cursor in the screen and “grabs” the divider so you can reposition it.
  • Current Open Files List: Shows all open tracks in the order they were loaded. The one with the check mark is the “current” track to which all the relevant menu items will be applied.
Help Menu

Help[edit]

  • Help: Opens the help file.
  • Report a Bug: Opens the OpenMPT Issue Tracker in your default Internet browser, where you can report a bug. (Obviously this only works if your computer is online.)
  • Example Modules: Shows a list of example tunes that are shipped with OpenMPT.
  • Show Settings Folder: Opens the folder containing all the configuration files.
  • OpenMPT Website: Opens the OpenMPT front page in your default Internet browser (openmpt.org).
  • Web Resources: Opens a list of interesting web resources related to OpenMPT in your default Internet browser.
  • Check for Updates: Manually runs the online update check.
  • About OpenMPT: Shows OpenMPT’s About window that displays the credits for OpenMPT and links to its website.